CommCell Console - Advanced

Table of Contents

Running the CommCell Console

The CommCell Console can be run in two ways:

The following sections describe the steps to run the CommCell Console as a stand-alone and remote web-based application.

Running the Console as a Stand-Alone Application

The stand-alone version of the CommCell Console can be run either locally from the CommServe computer or remotely on a client computer. The CommCell Console is automatically installed during the CommServe installation.

To access the CommCell Console as a stand-alone application, verify the following:

  • The version of the CommCell Console you are using is the same version as the CommServe.
  • The CommCell Console release level must be the same as the CommServe release level. Otherwise, the CommCell Console must be run as a remote web-based application.

Use the following steps to run the CommCell Console as a stand-alone application on a Windows, Macintosh, or Linux computer:

On Windows

On Windows 8 and Windows Server 2012 computers, click the Windows Start menu, and from the list of apps, under NetApp, click NetApp Administrative Console.

On computers older than Windows 8 and Windows Server 2012:

  1. From the Windows Start menu, click All Programs.
  2. From the list of programs, click NetApp > NetApp Administrative Console.

On Macintosh and Linux

  1. Log on as a root user to the computer that has the CommCell Console (stand-alone application version) installed.
  2. From a Terminal window, type console and press Return.

    The Connect to CommCell window is displayed.

  3. Enter the User Name, Password, and name of the CommCell you wish to connect to.
  4. Click OK to log on.

Running the Console as a Stand-Alone Application in a Specific Language

To access the CommCell Console as a Stand-Alone Application in a specific language, you need the following:

  • The correct version of the JRE, as stated in System Requirements - CommCell Console as a Stand-Alone Application.
  • The ISO Language and Country codes for the supported language in which you would like to run the application. (For information on supported languages, see Support Information - Languages.)

    Some commonly used ISO Language and Country codes are:

    • English: -Duser.language=en -Duser.country=US
    • Chinese: -Duser.language=zh -Duser.country=CN
    • German: -Duser.language=de -Duser.country=DE
    • Spanish: -Duser.language=es -Duser.country=MX

Use the following steps to run the CommCell Console as a Stand-Alone Application in a specific language:

  1. On your desktop, find the CommCell Console stand-alone application shortcut.

    Tip: Right-click the shortcut and make a copy of the shortcut before making changes.

  2. Right-click on the shortcut, and select Properties.
  3. In the Target field, add the appropriate ISO language and country codes in front of -jar.

    Example

    To start the application in French, type the following into the Target field:

    "C:\Program Files\Java\java_version\bin\javaw.exe" -Duser.language=fr -Duser.country=FR -jar cv.jar commserve_host.company.com 8401 -oemid= 1

    where:

    • java_version is the Java version, for example, jre7
    • commserve_host.company.com is the CommServe host name
  4. Click OK to save the changes.
  5. Double-click the shortcut to run the application.

Running the CommCell Console as a Remote Web-Based Application

You can access the CommCell Console remotely from any computer using a Java-enabled web browser. The web-based version of the CommCell Console uses the Java Web Start application and has the same appearance and functionality as the installable CommCell Console application.

To configure the CommCell Console as a web-based application, see Configuring Web Administration.

Use the following steps to run the CommCell Console as a remote web-based application:

If you are using a Linux computer, make a symlink to /usr/java/j*/jre/plug-ins/i386/ns610/libjavaplugin_oji.so in the ~/mozilla/plugins directory.

  1. Open a Java-enabled web browser from any computer that can connect to the CommCell Console computer.
  2. Type the URL of the computer where the CommCell Console is installed:
    • The default URL: http://<CommServe_name>:<port>/console
    • The URL If you are using the IIS of an alternate computer: http://<name of computer with IIS installed>:<port>/<web_alias>

      For information on installing the CommCell Console on an alternate computer, see Configuring Web Administration.

  3. If this is the first time you are accessing the CommServe remotely and the Java plug-in is not installed, the Java plug-in installation window will come up. Follow the instructions to download and install it.
  4. The Java Web Start application opens the JNLP file, which launches the CommCell Console as a web-based application. Depending on the web browser being used, the JNLP file is handled as follows:

    On Internet Explorer (IE)

    The Java Web Start application automatically opens the JNLP file and launches the Connect to CommCell window.

    On Mozilla Firefox

    The browser prompts you to open or save the JNLP file. Perform one of the following operations:

    • Select Open with and click the Do this automatically for files like this from now on check box to skip this prompt and to make the Java Web Start application open automatically the file in the future.
    • If you want to open the JNLP file from your computer in the future, select Save File. Make sure to move the file to a good location, such as the Desktop.

    On Google Chrome

    The browser prompts you to keep or discard the JNLP file. Follow the steps to open the file:

    1. At the bottom of the browser window, click Keep to download and open the file.
    2. Click the JNLP file.
    3. From the Security Warning window, accept to run the application and then click Run.

    On Safari 6.0.3 or higher (only MAC computers)

    This Safari version turns off the automatic execution of Java applets. Due to this, the Java Web Start application will fail to download and open the JNLP file.

    To enable the Java plug-in, follow the steps described in the About Safari 6.0.4 and 5.1.9 article.

    On Safari 5.1.7 or higher (Windows and MAC computers)

    1. When the browser prompts you to open or save the JNLP file do one of the following:
      • Click Open.
      • Click Save if you want to open the file from your computer.
    2. From the Security Warning window, accept to run the application and then click Run.
  5. On the Connect to CommCell window, provide the user account credentials to access the CommCell Console, and then click OK.

Using the CommCell Console

The following table displays the different operations that you can perform from the windows within the CommCell Console:

Operation Procedure
Navigate Console Windows You can configure the views of the CommCell Console panes, tabs and windows.

Navigate to the CommCell Console toolbar and click the View tab to perform the following operations:

  1. Navigate through all the open windows using the Previous Windows and Next Window options.

    You can also navigate through the open windows using the ctrl+tab function.

  2. Close the selected window or all windows
  3. Maximize all windows
  4. Reset the default layout
  5. Tile the windows horizontally or vertically
  6. Show the tasks and status bar
  7. Refresh the console
Find a Window Entity

To find an entity in a window:

  1. From the CommCell Console, while focus in on either the Job Controller or Event Viewer window, perform either of the following:
    • Right-click any field within the associated window.

      OR

    • Click the Table Menu icon at the upper right hand corner of the associated window.

    The Find option is displayed at the bottom of the menu.

  2. Click Find.

    A space to enter the entity you wish to find appears at the bottom of the associated window.

  3. Type the entity you wish to find in the space provided.

If the entity exists in the associated window, it will be highlighted.

Filter the Contents of a Window

To filter the contents of a window:

  1. From the CommCell Console, while focus in on either the Job Controller or Event Viewer window, perform either of the following:
    • Right-click any field within the associated window.

      OR

    • Click the Table Menu icon at the upper right hand corner of the associated window.

    The Filter option is displayed at the bottom of the menu.

  2. Click Filter.

    An arrow will appear in the upper right hand corner of each field in the associated window.

  3. Click on the arrow for the field containing the entities you wish to filter.

    A pull-down menu with all available entities in the associated field is displayed.

  4. Select the entity by which you wish to filter the window from the menu of available entities.

The window is filtered by the entity selected.

Print the Contents of a Window

To print the contents of a window:

  1. From the CommCell Console, while focus in on either the Job Controller or Event Viewer window, perform either of the following:
    • Right-click any field within the associated window.

      OR

    • Click the Table Menu icon at the upper right hand corner of the associated window.

    The Print option is displayed at the bottom of the menu.

  2. Click Print.

    A dialog box with the available printers will appear.

  3. Edit the printing options as necessary.
  4. Click OK.
Save the Contents of a Window to a File

To save the contents of a window to a file:

  1. From the CommCell Console, while focus in on either the Job Controller or Event Viewer window, perform either of the following:
    • Right-click any field within the associated window.

      OR

    • Click the Table Menu icon at the upper right hand corner of the associated window.

    The Save to File option is displayed at the bottom of the menu.

  2. Click Save to File.

    The Save dialog box is displayed.

  3. Navigate to the folder to which you wish to save the file.
  4. Choose a name and format for the file (if you do not wish to use the default name and format).
  5. Click OK.
Email the Contents of a Window

To email the contents of a window:

  1. From the CommCell Console, while focus in on either the Job Controller or Event Viewer window, perform either of the following:
    • Right-click any field within the associated window.

      OR

    • Click the Table Menu icon at the upper right hand corner of the associated window.

    The Email option is displayed at the bottom of the menu.

  2. Click Email.

    The SMTP Parameters dialog box is displayed.

  3. Enter one or more email addresses to send the contents of the window to.
  4. Modify the SMTP settings, if necessary.
  5. Click OK.
Viewing Installed Components You can view a list of software components installed on a given client computer by right-clicking the client computer, selecting View, and then selecting Installed Software. This dialog box will show all components installed on the client, including those that do not appear as separate components under the client node in the CommCell Console (such as Offline Mining components).

Configuring the Maximum Number of Console Connections

Use the following steps to configure the maximum number of users that can connect to the CommCell Console:

  1. From the command prompt, navigate to software_installation_directory/Base and run the following command:

    qlogin -cs <commserve name> -u <user name>

  2. Execute the following command:

    qoperation execscript -sn SetKeyIntoGlobalParamTbl.sql -si MaxJavaConnections -si y -si Max_Number

    where the Max_Number variable is the number of connections allowed in the CommCell Console.

Hiding CommCell Elements

You can hide features and options that users can access in the CommCell Console. For example, certain users do not need access to all options in the CommCell, particularly administrative functions.

The CV_Restricted_Visibility user group must be created to hide CommCell elements from selected users. When assigned to this user group, members can see only a portion of all available options in the CommCell. The following elements are excluded from the restricted view of the CommCell Console:

  • Tools menu
  • Toolbar buttons including Alert, Scheduler, Control Panel, and Web Console
  • CommCell Browser nodes including Security, Storage Resources, Policies, Content Director, and Workflows
  • At the CommCell root node, the right-click menu and all related options
  • At the Client Computers node, all options on the right-click menu, except for Customize View
  • At each client computer node, the Properties and Send Log Files options on the right-click menu

The following elements are included in the restricted view of the CommCell Console:

  • Menus including Home, Reports, View, and Support.
  • Toolbar buttons including CommCell, Job Controller, Event Viewer, What's New, and Getting Started
  • CommCell Browser nodes including the CommCell root node, Client Computers, and Reports
  • The Customize View option on the right-click menu of the Client Computers node
  • All options on the right-click menu for each client computer node, except for Properties and Send Log Files

Use the following steps to hide CommCell elements from selected users.

  1. From the CommCell Browser, right-click the CommCell root node, then select Properties.
  2. In the CommCell Properties dialog box, select the Additional Settings tab and click Add.
  3. In the Name box, type nRestrictedViewEnabled.

    Once entered, the Category and Type details will be automatically populated.

  4. In the Value box, type 2.
  5. Click OK.
  6. Click OK to close the Properties dialog box.
  7. Restart the CommCell services.

    When the CommCell services restart, the CV_Restricted_Visibility user group will appear under the Security > CommCell User Groups node.

  8. From the CommCell Browser, go to Security > CommCell User Groups.
  9. Right-click the CV_Restricted_Visibility user group and then click Properties.
  10. In the Users tab, move users that should have the restricted view from the Available Users list to the Member Users list.

    Ensure that you assign a user to at least one other user group (for example, View All user group), otherwise that user will not be able to access the CommCell Console.

Once a user is added to the CV_Restricted_Visibility user group, the user will have a restricted view of the CommCell Console as shown below:

Customizing the CommCell Console

Customizing Columns and Windows

All windows containing multiple entities provide several options for displaying, searching, and manipulating those entities. You can access these options in the following ways:

  • as a right-click menu for any field in the active window.
  • from the Table Menu located at the upper right hand corner of the active window.

The following options are available for all windows containing multiple entities:

Option Description
Auto Resize This Column "<column name>" Resizes the selected column to the default size. See Change Table Views for step-by-step instructions.
Auto Resize All Columns Resizes all columns in the selected window to the default size. See Change Table Views for step-by-step instructions.
Select All the Cells Places focus on all fields in the selected window. See Change Table Views for step-by-step instructions.
Clear Selection Removes focus from all fields in the selected window. See Change Table Views for step-by-step instructions.
Horizontal Scroll Resizes all columns to fit the data displayed in the column's fields. See Change Table Views for step-by-step instructions.
Choose Columns Provides the facility to select or deselect columns to be viewed in the selected window. See Change Table Views for step-by-step instructions.
Save Saves the status of all entities in the active window to a file. You can choose to save this information in .csv, .pdf, or .xls formats. See Save the Contents of a Window to a File for step-by-step instructions.
Email Provides the facility to create a new email message and select a file format in which the component will be attached to the message (.pdf or .xls). See Email the Contents of a Window for step-by-step instructions.
Print Prints the status of all entities in the active window. See Print the Contents of a Window for step-by-step instructions.
Paragraph Changes the columns to a paragraph view. See Change Table Views for step-by-step instructions.
Find Provides space at the bottom of the window in which you can type the entity you wish to find. See Find a Window Entity for step-by-step instructions.
Filter Provides the facility to narrow information in the active window down to a specific entity. See Filter the Contents of a Window for step-by-step instructions.
Group by Groups entities together based on the column title selected. See Change Table Views for step-by-step instructions.

Modifying the Look and Feel

For user preferences to take effect, the user must log out and log back into the CommCell Console.

Operation Procedure
Change the Default Time Zone To change the time zone:
  1. On the CommCell Console ribbon, click the Tools tab, and then click User Preferences.
  2. From the Date and Time formats tab, select the time zone to use in the CommCell Console.
Change the Default Date and Time Formats To change the date and time formats:
  1. On the CommCell Console ribbon, click the Tools tab, and then click User Preferences.
  2. From the Date and Time formats tab, select the date and time formats to use in the CommCell Console.
Select an Interface Style To select a CommCell Console windows style:
  1. On the CommCell Console ribbon, click the View tab.
  2. Select the desired layout.
Change the Default User Preferences Display

To navigate to User Preferences:

  1. On the CommCell Console ribbon, click the Tools tab, and then click User Preferences.
  2. From the General tab, select Use this browser to open HTML files to open HTML files.
  3. Use the lookup button to select the browser.
  4. Select Display Floating Restore Progress Bar on Submission of Restore Job to view progress bar.
  5. Click OK to save your changes.
Select the Default Windows to Display Upon Login

To select the default CommCell windows to display upon login:

  1. On the CommCell Console ribbon, click the Tools tab, and then click User Preferences.
  2. From the General tab, select the appropriate options to save the settings for the CommCell Browser, Job Controller, Event Viewer windows.

    You can also choose to save the table preferences set for the Job Controller and Event Viewer windows by clicking the Save Table Preferences option.

  3. Click OK to save your changes.

    The CommCell Console will remember the window display preferences used on your next logout and retain those preferences for your subsequent login.

Add or Remove Tool Bars

To add or remove toolbars:

  1. On the CommCell Console ribbon, click the View tab.
  2. Select Tasks or Status Bar to enable/disable the option. A checkmark will appear next to the option when it is enabled.
Change Job Controller Display

To change the default display for the Job Controller window:

  1. On the CommCell Console ribbon, click the Tools tab, and then click User Preferences.
  2. From the Jobs tab, enter the time in seconds for job retention in the Retention Time (Secs) box.
  3. Click OK to save your changes.
Change Event Viewer Display

To change the default display for the Event Viewer window:

  1. On the CommCell Console ribbon, click the Tools tab, and then click User Preferences.
  2. From the Event Filter tab, select the severity levels that you want to see in the Event Viewer.
  3. Type the maximum number of events to be displayed in the Event Viewer (Default = 200).
  4. Click OK to save your changes.
Change Table Views

To change the table views for the Job Controller and the Event Viewer windows:

  1. From the Job Controller or Event Viewer windows in the CommCell Console, right-click any field within the window.

    The available options for the window are displayed.

  2. Select or deselect the parameters you want presented in the window.
Save Table Views

To save the table views for the Job Controller and the Event Viewer windows:

  1. On the CommCell Console ribbon, click the Tools tab, and then click User Preferences.
  2. Click Save Table Preferences.
  3. Click OK.

Customizing Language Settings

The CommCell® Console can be viewed in a variety of different languages. For information on supported languages, see Support Information - Languages.

By default, the CommCell Console will be displayed in the supported language currently running on your operating system. For example, if you are running the CommCell Console on a Windows computer, the CommCell Console will be displayed in the language set in the Regional and Language Options dialog box provided that language is supported by the software. Conversely, if the language running on your operating system is not supported by the software, the CommCell Console will be displayed in English.

If you wish to run the CommCell Console in a supported language that is different from the language used for your operating system (for example, you wish to run the CommCell Console in Italian while your operating system runs in English), you can configure the CommCell Console to run in the supported language by modifying the CommCell Console's Java command parameters. Note that the appropriate fonts and characters for the supported language must be available on the computer. For more information, see CommCell Console.

To run the CommCell Console as a remote web-based application in a non-English language, Active Server Pages must be enabled in the IIS Server of the computer on which the stand-alone CommCell Console is installed.

To modify the JRE installation to the language of your operating system, use Additional languages option. See the following steps:

Modify the JRE Installation with Additional Languages Option

To modify the JRE Installation with languages:

  1. From the Start menu, select Control Panel.
  2. Select Add or Remove Programs (Programs and Features in Windows 2008), locate the JRE Entry and click Change.
  3. You will be prompted with Java Install Wizard, click Next (click Modify in Windows 2008).
  4. You will be prompted Custom Setup dialog box.
  5. Click Additional Language, and select "This features, and all sub features, will be installed on local hard drive".
  6. Click Next to install.
  7. Click Finish to Complete.

Users Logged In

A user can connect to the CommServe through the CommCell Console or through the Command Line Interface. You can view the users that are currently logged on to the CommServe and obtain the following information about each user:

  • user name
  • host name from where the user logged on
  • date and time the user logged on to the CommServe
  • amount of time the user has been inactive

Use the following steps to view the users that are currently logged in to the CommServe:

  1. From the CommCell Browser, right-click the CommServe node, and then click View > Users Logged In.

    The Users Logged In dialog box displays all of the CommCell Console and command line user sessions.

  2. Click Close.

You can also send instant messages or disconnect a user from the Users Logged In dialog box. For information on these operations, see Sending Instant Messages.

Alerts

An alert can be configured to send e-mail notifications to user groups created from within the CommCell Console as well as external domain user groups. However, individual external domain users will not receive the alert notification e-mail if they have not previously logged on to the CommCell Console. Users (from the user groups created from within the CommCell Console) will receive the alert e-mail notification regardless of their login status.

Reports

A scheduled report can be configured to be sent via e-mail to user groups created from within the CommCell Console as well as external domain user groups. However, individual external domain users will not receive the report via e-mail if they have not previously logged on to the CommCell Console. Users (from the user groups created from within the CommCell Console) will receive the report e-mail regardless of their login status.

Property Sheet Locking

Property sheet locking disables multiple users from editing the same property sheet at the same time. When a user opens a specific property sheet, all other users are locked out. If you are locked out of a property sheet, you will receive a message indicating which user has the sheet locked and you will be informed that the sheet is read-only. The modifications you made while the property sheet was read-only will not be saved. When the user that has the lock is finished with a property sheet, the lock is released appropriately and other users can modify the property sheet.

Property sheet locks will time out when a user has that sheet locked for more than 90 minutes. When the 90 minute time interval has elapsed, other users can modify the property sheet.

If a user accesses a property sheet from the backup set/instance level, all property sheets under these levels are locked. Additionally, if a user locks the subclient of a backup set/instance, then all property sheets of these level(s) are also locked.

If a user accesses a property sheet from a library, then all property sheets below that level are also locked. Additionally, if a user locks any property sheet under the library level, then those levels are also locked.