Storage Policy Copy - Troubleshooting

Table of Contents

General

Changing a data path while a job is running causes an error

Symptom

If you attempt to change the data path for a storage policy copy while a job is running for that copy, an error message appears.

Modifying data path for copy is not allowed since jobs are running for storage policy. Please wait for jobs to finish.

Resolution

  1. On the ribbon in the CommCell Console, click the Storage tab, and then click Media Management.

    The Media Management Configuration dialog box appears.

  2. On the Service Configuration tab, set the Allow change to data path configuration even if jobs are running option to 1.
  3. Try to change the data path again.

Restore job goes pending when a storage policy copy has a disabled data path

Symptom

The restore job go into Pending state with the following error.

Please check if all the disk library mount paths in the dedup storage policy copy are properly configured to read from the MediaAgent [ ]

Cause

The error occurs when the storage policy copy associated with the subclient or instance from which the restore job was run has a data path disabled.

Resolution

To resolve the issue, complete one of the following tasks.

  • Delete the disabled data path on a storage policy copy and then resume the restore job.
    1. To delete a data path, see Deleting a Data Path from a Storage Policy Copy for instructions.
    2. Right-click the appropriate restore job, and then click Resume.
  • Kill the pending restore job and run a new restore job by selecting the appropriate MediaAgent.
    1. Right-click the restore job that is in Pending state, and then click Kill.
    2. From the CommCell Browser, right-click the appropriate subclient or instance, and then click Browse and Restore.
    3. In the Browse and Restore Options dialog box, select the Advanced Options tab, select the MediaAgent from the Use MediaAgent list, and then click View Content.
    4. In the right pane of the Browse window, click the <Instance> and select all the entities and click Restore All Selected.
    5. In the Restore Options for All Selected Items dialog box, click OK.

Synchronous Copy

Specifying a source copy on the secondary copy causes an error

Symptom

When you specify a source copy for a secondary copy in Copy Policy tab in the Copy Properties dialog box, an error message might appear when the CommCell the entity that is associated with the source copy is different from the entity that is associated with the secondary copy.

Subclients associated to a secondary copy must also be associated to its source copy

Solution

Before specifying source copy, in the Association tab, make sure that:

  • Both the storage policy copies have same CommCell entities (clients or subclient and so on) associated
  • The secondary copy has a fewer CommCell entities associated than the source copy

See Assigning CommCell Entities to a Storage Policy Copy for more information on association of CommCell entities to a storage policy copy other than primary copy.

Selective Copy

Automatic copy not copying when there is new data to be copied

Symptom

New data is available in the source copy and you have created Auxiliary Copy schedule enabling Automatic Copy option. However no data is copied from the source copy to a secondary copy.

Cause

This scenario may arise due to following reasons:

  • You may have configured the Selective Copy with Do not Automatically Select jobs option and not selected any jobs manually.
  • You may have created Auxiliary Copy schedule with Automatic Copy option and Select Most Recent Recent Full Backup when Auxiliary Copy Starts.

Solution

When scheduling the auxiliary copy job, do not setup Automatic copy instead,

Inline Copy

Inline copy cannot be created with deduplication enabled, when the primary copy has multiplexing enabled

Inline Copy creation displays the following error message when enabling the deduplication option:

Inline copy cannot be created with deduplication enabled, when the primary copy has multiplexing enabled

Symptom

This error message will appear when you are creating inline copy with deduplication and the source copy has Multiplexing enabled.

Resolution

You cannot create Inline Copy with deduplication when Primary (or source) copy has Multiplexing enabled. This is because Data Multiplexing is not supported with the Deduplication.