Loading...

Enabling 32-Bit Installations on 64-Bit Linux Computers

By default, 64-bit agents are installed on Linux computers.

If you have a 64-bit Linux computer and you need to protect 32-bit applications, you can configure the installation program to install 32-bit agents.

Prerequisites

At a minimum, the following 32-bit libraries must be installed on the 64-bit Linux computer:

  • C and C++ runtime libraries, such as libc6-i386 and lib32stdc++6, or equivalents
  • Compression libraries, such as lib32z1 or equivalent
  • Access control lists libraries, such as libacl.i386 or equivalent

Procedure

Use one of the following methods to enable 32-bit installations:

Preferred Method: Using the CommCell Console (Remote Installation)

During a remote installation, on the UNIX Advanced Options page of the installation wizard, select the Install 32-bit instead of default 64-bit packages (Linux_x86_64 only) - This will protect 32-bit applications only check box.

For instructions on remote installations, see Installing SnapProtect Remotely Using the CommCell Console.

Alternative Method: Using the Installation Package (Local Installation)

Before you run the installation package, create a lock file on the 64-bit computer by running the following command:

touch /tmp/cvpkgadd_unlock_32

After the file is created, you can install 32-bit agents by running the installation package. For instructions, see Installing SnapProtect Locally on UNIX, Linux, and Macintosh Computers Using the Installation Package.