Loading...

Installing Clients from Older SnapProtect Versions

If the operating system of a computer is no longer supported by the current SnapProtect version, you can install the SnapProtect version that last supported the operating system and associate the computer with your current CommCell environment. For information on the operating systems that became deprecated in this version, see End-of-Life, Deprecated and Extended Support - Platforms.

The current SnapProtect version supports up to the last two previous versions. For example, if you have a Version 11 CommCell environment, you can install a Version 10 or Version 9 client.

To enable the installation of older SnapProtect versions, you must set some additional settings on the computers where you want to install the software, as well as the CommServe computer.

Before You Begin

  • Obtain the software for the SnapProtect version that you want to install.
  • The nAllowOlderClients additional setting must be configured on the CommServe computer.
    1. From the CommCell Browser, right-click the CommServe and then click Properties.
    2. In the CommCell Properties dialog box, click the Additional Settings tab and then click Add.
    3. In the Add Additional Settings on Windows Client dialog box, complete the following steps:
      1. In the Name box, type nAllowOlderClients.
      2. In the Value box, type 1.
      3. Click OK.

Procedure

Follow the steps that correspond to the operating system of your computer.

On Windows Computers

  1. Create the bIgnoreCommServeVersion registry key by using the Windows Registry Editor.
    1. On the Windows computer, open the Windows Registry Editor and navigate to the HKEY_LOCAL_MACHINE\SOFTWARE\ directory.
    2. Right-click SOFTWARE and click New -> Key.
    3. Name the key as GalaxyInstallerFlags.
    4. Right-click GalaxyInstallerFlags and select New -> DWORD value. Name the key as bIgnoreCommServeVersion.
    5. Double-click the bIgnoreCommServeVersion key and modify the Value data to 1.
  2. Run the installation package and follow the installation wizard.

On UNIX Computers

From the installation package or mount point, run the following command and follow the installation wizard:

./cvpkgadd -allow-newer-commserve

Note: If you plan to install SnapProtect Version 9, you can also create a custom package and use the XML file to install the package silently. In the XML file, you must update the value of the allowNewerCommServe parameter to 1.