Loading...

Plan the Client Upgrade

After the CommServe and MediaAgent upgrade, you can upgrade the clients in your CommCell environment.

We recommend that MediaAgents are already upgraded before the client upgrade. However, clients and MediaAgents can be upgraded at the same time.

Use the following checklist to prepare for the upgrade:

  • Verify Supported SnapProtect Versions

    • Version 9 clients must have service pack 3 or later.
    • Version 10 clients do not have a service pack requirement.

    Note: For any of the SnapProtect versions, we recommend that you always install the latest service pack.

  • Verify System Requirements

    Make sure that the clients satisfy the minimum requirements for the new SnapProtect software.

    From the System Requirements home page, select the agent or other software that is installed on the client to review its system requirements.

  • Verify License Requirements

    You do not need a license to upgrade clients to V11. After the upgrade, you can continue to perform your day-to-day CommCell operations.

    In V10, several licenses were renamed and deprecated. If you are V9 user and a CommCell feature was deprecated in V10, the feature will be unavailable after the upgrade.

    For more information, review the following V10 documentation topics:

  • Decide Which Clients To Upgrade

    You can choose not to upgrade all the clients in your CommCell environment. However, you will not benefit from the new features in the current SnapProtect version.

    We recommend that you schedule the client upgrade based on geographic locations and importance of applications.

    Important:

    • If MediaAgents are associated with the clients that you plan to upgrade, make sure that the MediaAgents are also upgraded. If a client is upgraded and its associated MediaAgent is not, new features will not be available for the client.

      To review the supported MediaAgent and client mixed versions, see Support for Mixed MediaAgent and Client Versions.

    • For optimal and reliable performance, the CommServe and clients should always operate at the same version and service pack level.
  • Determine Whether You Have Version 8 Clients Running UNIX and NetWare File System Agents

    V8 clients cannot be upgraded to V11. However, you can continue to protect the file system data of UNIX and NetWare V8 clients in your V11 CommCell environment.

    To benefit from this extended support, the V8 clients must run one of the following operating systems:

    • AIX 5.2
    • NetWare
    • Red Hat Linux 3.8
    • SuSE Linux 9.x
    • Ubuntu 7.x

    Important: You can only perform basic backup and restore operations for UNIX and NetWare File System Agents. Other agents, including driver-based agents, and advanced features, such as firewall configurations, are not supported. Make sure that the CommServe computer and MediaAgents have open ports for V8 clients so that the clients can establish direct connections.

  • Review the Restart Requirements for Database Agents

    Certain database agents require that you restart the database services during the upgrade process.

    If the client has database agents installed, refer to the following topics to determine whether the agents require a database restart: