Loading...

CommCell Console - Advanced

Table of Contents

Using the CommCell Console

The following table displays the different operations that you can perform from the windows within the CommCell Console:

Operation Procedure
Navigate Console Windows You can configure the views of the CommCell Console panes, tabs and windows.

From the CommCell Console ribbon, on the View tab, you can perform the following operations:

  • Navigate through all the open windows using the Previous Windows and Next Window options.

    You can also navigate through the open windows using the ctrl+tab function.

  • Close the selected window or all windows.
  • Maximize all windows.
  • Reset the default layout.
  • Tile the windows horizontally or vertically.
  • Show the tasks and status bar.
  • Refresh the console.
Find a Window Entity

To find an entity in a window:

  1. From the CommCell Console, while focus in on either the Job Controller or Event Viewer window, perform either of the following:
    • Right-click any field within the associated window.

      OR

    • Click the Table Menu icon at the upper right hand corner of the associated window.

    The Find option is displayed at the bottom of the menu.

  2. Click Find.

    A space to enter the entity you wish to find appears at the bottom of the associated window.

  3. Type the entity you wish to find in the space provided.

If the entity exists in the associated window, it will be highlighted.

Filter the Contents of a Window

To filter the contents of a window:

  1. From the CommCell Console, while focus in on either the Job Controller or Event Viewer window, perform either of the following:
    • Right-click any field within the associated window.

      OR

    • Click the Table Menu icon at the upper right hand corner of the associated window.

    The Filter option is displayed at the bottom of the menu.

  2. Click Filter.

    An arrow will appear in the upper right hand corner of each field in the associated window.

  3. Click on the arrow for the field containing the entities you wish to filter.

    A pull-down menu with all available entities in the associated field is displayed.

  4. Select the entity by which you wish to filter the window from the menu of available entities.

The window is filtered by the entity selected.

Print the Contents of a Window

To print the contents of a window:

  1. From the CommCell Console, while focus in on either the Job Controller or Event Viewer window, perform either of the following:
    • Right-click any field within the associated window.

      OR

    • Click the Table Menu icon at the upper right hand corner of the associated window.

    The Print option is displayed at the bottom of the menu.

  2. Click Print.

    A dialog box with the available printers will appear.

  3. Edit the printing options as necessary.
  4. Click OK.
Save the Contents of a Window to a File

To save the contents of a window to a file:

  1. From the CommCell Console, while focus in on either the Job Controller or Event Viewer window, perform either of the following:
    • Right-click any field within the associated window.

      OR

    • Click the Table Menu icon at the upper right hand corner of the associated window.

    The Save to File option is displayed at the bottom of the menu.

  2. Click Save to File.

    The Save dialog box is displayed.

  3. Navigate to the folder to which you wish to save the file.
  4. Choose a name and format for the file (if you do not wish to use the default name and format).
  5. Click OK.
Email the Contents of a Window

To email the contents of a window:

  1. From the CommCell Console, while focus in on either the Job Controller or Event Viewer window, perform either of the following:
    • Right-click any field within the associated window.

      OR

    • Click the Table Menu icon at the upper right hand corner of the associated window.

    The Email option is displayed at the bottom of the menu.

  2. Click Email.

    The SMTP Parameters dialog box is displayed.

  3. Enter one or more email addresses to send the contents of the window to.
  4. Modify the SMTP settings, if necessary.
  5. Click OK.
Viewing Installed Components You can view a list of software components installed on a given client computer by right-clicking the client computer, selecting View, and then selecting Installed Software. This dialog box will show all components installed on the client, including those that do not appear as separate components under the client node in the CommCell Console (such as Offline Mining components).

Configuring the Maximum Number of Console Connections

You can configure a maximum number for the number of users who can connect to the CommCell Console.

  • To the CommServe computer, add the MaxJavaConnections additional setting as shown in the following table.

    For instructions on adding the additional setting from the CommCell Console, see Add or Modify an Additional Setting.

    Property Value
    Name MaxJavaConnections
    Category CommServDB.GxGlobalParam
    Type Integer
    Value The number of connections allowed

Hiding CommCell Elements

You can hide features and options that users can access in the CommCell Console. For example, certain users do not need access to all options in the CommCell, particularly administrative functions.

The CV_Restricted_Visibility user group must be created to hide CommCell elements from selected users. When assigned to this user group, members can see only a portion of all available options in the CommCell. The following elements are excluded from the restricted view of the CommCell Console:

  • Tools menu
  • Toolbar buttons including Alert, Scheduler, Control Panel, and Web Console
  • CommCell Browser nodes including Security, Storage Resources, Policies, Content Director, and Workflows
  • At the CommCell root node, the right-click menu and all related options
  • At the Client Computers node, all options on the right-click menu, except for Customize View
  • At each client computer node, the Properties and Send Log Files options on the right-click menu

The following elements are included in the restricted view of the CommCell Console:

  • Menus including Home, Reports, View, and Support.
  • Toolbar buttons including CommCell, Job Controller, Event Viewer, What's New, and Getting Started
  • CommCell Browser nodes including the CommCell root node, Client Computers, and Reports
  • The Customize View option on the right-click menu of the Client Computers node
  • All options on the right-click menu for each client computer node, except for Properties and Send Log Files

Use the following steps to hide CommCell elements from selected users.

  1. From the CommCell Browser, right-click the CommCell root node, then select Properties.
  2. In the CommCell Properties dialog box, select the Additional Settings tab and click Add.
  3. In the Name box, type nRestrictedViewEnabled.

    Once entered, the Category and Type details will be automatically populated.

  4. In the Value box, type 2.
  5. Click OK.
  6. Click OK to close the Properties dialog box.
  7. Restart the CommCell services.

    When the CommCell services restart, the CV_Restricted_Visibility user group will appear under the Security > CommCell User Groups node.

  8. From the CommCell Browser, go to Security > CommCell User Groups.
  9. Right-click the CV_Restricted_Visibility user group and then click Properties.
  10. In the Users tab, move users that should have the restricted view from the Available Users list to the Member Users list.

    Ensure that you assign a user to at least one other user group (for example, View All user group), otherwise that user will not be able to access the CommCell Console.

Once a user is added to the CV_Restricted_Visibility user group, the user will have a restricted view of the CommCell Console as shown below:

Customizing the CommCell Console

Customizing Columns and Windows

All windows containing multiple entities provide several options for displaying, searching, and manipulating those entities. You can access these options in the following ways:

  • as a right-click menu for any field in the active window.
  • from the Table Menu located at the upper right hand corner of the active window.

The following options are available for all windows containing multiple entities:

Option Description
Auto Resize This Column "<column name>" Resizes the selected column to the default size. See Change Table Views for instructions.
Auto Resize All Columns Resizes all columns in the selected window to the default size. See Change Table Views for instructions.
Select All the Cells Focuses on all fields in the selected window. See Change Table Views for instructions.
Clear Selection Removes focus from all fields in the selected window. See Change Table Views for instructions.
Horizontal Scroll Resizes all columns to fit the data displayed in the column's fields. See Change Table Views for instructions.
Choose Columns Select or clear columns to view in the selected window. You can select or clear multiple columns by holding down the Ctrl key. See Change Table Views for instructions.
Save Saves the status of all entities in the active window to a file. You can choose to save this information in .csv, .pdf, or .xls formats. See Save the Contents of a Window to a File for instructions.
Email Creates a new email message and select a file format in which the component will be attached to the message (.pdf or .xls). See Email the Contents of a Window for instructions.
Print Prints the status of all entities in the active window. See Print the Contents of a Window for instructions.
Paragraph Changes the columns to a paragraph view. See Change Table Views for instructions.
Find Opens a Find box at the bottom of the window. Type the name of the entity you wish to find. See Find a Window Entity for instructions.
Filter Adds an arrow to the column heading. Click the arrow to filter the column values. See Filter the Contents of a Window for instructions.
Group by Groups entities together based on the column title selected. See Change Table Views for instructions.

Modifying the Look and Feel

For user preferences to take effect, the user must log out and log back into the CommCell Console.

Operation Procedure
Change the Default Time Zone To change the time zone:
  1. On the CommCell Console ribbon, click the Tools tab, and then click User Preferences.
  2. From the Date and Time formats tab, select the time zone to use in the CommCell Console.
Change the Default Date and Time Formats To change the date and time formats:
  1. On the CommCell Console ribbon, click the Tools tab, and then click User Preferences.
  2. From the Date and Time formats tab, select the date and time formats to use in the CommCell Console.
Select an Interface Style To select a CommCell Console windows style:
  1. On the CommCell Console ribbon, click the View tab.
  2. Select the desired layout.
Change the Default User Preferences Display

To navigate to User Preferences:

  1. On the CommCell Console ribbon, click the Tools tab, and then click User Preferences.
  2. From the General tab, select Use this browser to open HTML files to open HTML files.
  3. Use the lookup button to select the browser.
  4. Select Display Floating Restore Progress Bar on Submission of Restore Job to view progress bar.
  5. Click OK to save your changes.
Select the Default Windows to Display Upon Login

To select the default CommCell windows to display when you log on:

  1. On the CommCell Console ribbon, click the Tools tab, and then click User Preferences.
  2. From the General tab, select the appropriate options to save your settings:
    • To keep the last tab opened in the tool bar menu, click Save Ribbon State.
    • To save the table preferences for the tables in the following windows, click the Save Table Preferences option:
      • Admin Job History
      • Backup Job History
      • Event Viewer
      • Job Controller
      • Restore Job History
  3. Click OK to save your changes.

    The CommCell Console will remember the window display preferences used on your next logoff and retain those preferences for your subsequent logon.

Add or Remove Tool Bars

To add or remove toolbars:

  1. On the CommCell Console ribbon, click the View tab.
  2. Select Tasks or Status Bar to enable/disable the option. A checkmark will appear next to the option when it is enabled.

When you close the CommCell Console, your preferences are saved.

Change Job Controller Display

To change the default display for the Job Controller window:

  1. On the CommCell Console ribbon, click the Tools tab, and then click User Preferences.
  2. From the Jobs tab, enter the time in seconds for job retention in the Retention Time (Secs) box.
  3. Click OK to save your changes.
Change Event Viewer Display

To change the default display for the Event Viewer window:

  1. On the CommCell Console ribbon, click the Tools tab, and then click User Preferences.
  2. From the Event Filter tab, select the severity levels that you want to see in the Event Viewer.
  3. Type the maximum number of events to be displayed in the Event Viewer (Default = 200).
  4. Click OK to save your changes.
Change Table Views

To change the table views in windows, for example, in the Job Controller window:

  1. From a window in the CommCell Console, right-click any column in the window.

    The available options for the column are displayed.

  2. Select or deselect the parameters you want presented in the window.

When you close the CommCell Console, your preferences are saved. To save your preferences without closing the CommCell Console, in the bottom right of the console, on the status bar, click the Save User Preferences icon.

Save Table Views

To save the table preferences for the tables in the following windows:

  • Admin Job History
  • Backup Job History
  • Event Viewer
  • Job Controller
  • Restore Job History
  1. On the CommCell Console ribbon, click the Tools tab, and then click User Preferences.
  2. Click Save Table Preferences.
  3. Click OK.

Viewing the Users Logged On to the CommServe

A user can connect to the CommServe through the CommCell Console or through the Command Line Interface. You can view the users that are currently logged on to the CommServe and obtain the following information about each user:

  • user name
  • host name from where the user logged on
  • date and time the user logged on to the CommServe
  • amount of time the user has been inactive

Procedure

  1. From the CommCell Browser, right-click the CommServe node, and then click View > Users Logged In.

    The Users Logged In dialog box displays all of the CommCell Console and command line user sessions.

  2. Click Close.

You can also send instant messages or disconnect a user from the Users Logged In dialog box. For information on these operations, see Sending Instant Messages.

Alerts

An alert can be configured to send e-mail notifications to user groups created from within the CommCell Console as well as external domain user groups. However, individual external domain users will not receive the alert notification e-mail if they have not previously logged on to the CommCell Console. Users (from the user groups created from within the CommCell Console) will receive the alert e-mail notification regardless of their login status.

Reports

A scheduled report can be configured to be sent via e-mail to user groups created from within the CommCell Console as well as external domain user groups. However, individual external domain users will not receive the report via e-mail if they have not previously logged on to the CommCell Console. Users (from the user groups created from within the CommCell Console) will receive the report e-mail regardless of their login status.

Property Sheet Warning

When a user opens a property sheet (dialog box) that is already opened by another user, an overwrite warning appears. The warning includes the name of the other user. If all of the users make changes to the property sheet, only the changes made by the last user are saved.